Bug reports & Feedback

Hello Extinction Elites,

The war is just about to begin!

If you encounter any bugs in your fight to reclaim earth, please let us know so we can make the technical part of the war as smooth as possible. You’ll have to take care of the dinosaur threat.

Please report the bugs you encounter here with as many details as you can so we can find and fix it as fast as we can.

If you have any feedback, we’d greatly appreciate it if you can put it in the #game-feedback channel on our discord server (discord.gg/secondextinction), so we don’t miss it. You are, of course, welcome to share it here, but for the fastest response from the team, we recommend the discord. (There are also many more people to share your thoughts and talk about the game with.)

We hope you enjoy the game and don’t hesitate to let us know what you think!


Dint even have accsss wht happend

What don’t you have access to?

I start any mission and with 10 seconds the game says I failed mission. I tried to play with both myself and with a party member and still the same thing happened. Is this a bug or something I’m doing wrong.

I’ve filled out a bug report form, the thing is that after about a minute of play the game minimises to the task bar. I’ve tried other games in my Steam library even Generation Zero and it does not happen, only with Second Extinction and this only started after the update, really frustrating (hope I don’t have to wait for the next update).


Now that I can play the game, I had trouble at first until support helped me, I really enjoy it. I find it very hard to complete a mission. I’ve actually died, with no respawns, as the evacuation ship was landing… But my real problem is; the Dino parts I can collect disappear way too soon! It usually takes me a couple of minutes, or longer, to wipe out the hordes that are attacking. By then there are no body parts to collect… And as we all know, those are vital for upgrading. :crazy_face:

On the mission where you hold the center (close the 2 gates) if you have a team that know what has to be done and closes the gates immediately, the Rex breaking the door down does not occur. I do not know if anyone else has experienced this glitch or not.

Just to let you know after reinstalling windows has seemed to fix the issue, my version of windows started to cause all sort of issues.

See video highlight of this annoying game breaking bug that dropship, grenades, placable does not show up.

Played a good whole hour.

Gifted the game to my friend and gave him a crash tour so we did the whole map on “Homestead” mission. Collected EVERYTHING with 5 star rating.

Was one supply left and it didnt spawn in, noticed other building didn’t spawn and my friend played Amir and his grenades did not fire out or damage, neither did my handheld thrown grenades.

If we progressed away the called supplies would be called when they were called like 2min ago.

Huge disappointment but hey its early access but what bad timing when introducing the game on the first play.

Last thing we tried was me logging off and rejoining did not fix it so my friend tried exiting to main menu then the game shut down for me and neither of us got any xp or loot.

Was just after the thought of dying might have given us at least something.

Thank you for letting us know about this! Sorry to hear you were experiencing so many issues. I’ve forwarded the video to the team.

If you can, please report the issues here: https://support.secondextinctiongame.com/hc/en-gb/articles/360017249719-Report-a-bug so we can get some more info, have a closer look, and get back to you if we have any more questions that could help us solve these bugs faster. Thank you!

No worries, sent a bug report on the link.

For whole playthrough section see the whole stream (note only last like 7-14days on twitch)
1hour 6minutes’ish in it starts

Thank you for that! :slight_smile:

The mission I was talking about is “contact”… but it seems there was a fix to this as you can now open the gates if the main one does not break down, thank you!

Is anyone having an issue with when using the grenade launcher after so long it makes your party lag out and it stops working? For me It just stopped doing damage and showing an explosion effect after around 20 mins in a game of me and my friend just camping the Vultus Bay Extraction. It was weird because he lagged out but I didn’t.


Could you please contact our support about this bug? If you happen to have a video, it would be greatly appreciated. You can contact us by following this guide - Bug